<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<link media="all" href="https://www.trillmag.com/wp-content/cache/autoptimize/css/autoptimize_726ece67dbd81853af4f3f30599b8c2d.css" rel="stylesheet" /><title>&#039;Shadow and Bone&#039; Season 2 Release Date: What We Know So Far - Trill Mag</title>
<meta name="description" content="Shadow and Bone, Know about Shadow and Bone season 2&#039;s Release Updates" />
<link rel="canonical" href="https://www.trillmag.com/entertainment/__trashed-14/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;Shadow and Bone&#039; Season 2 Release Date: What We Know So Far" />
<meta property="og:description" content="Shadow and Bone, Know about Shadow and Bone season 2&#039;s Release Updates" />
<meta property="og:url" content="https://www.trillmag.com/entertainment/__trashed-14/" />
<meta property="og:site_name" content="Trill Mag" />
<meta property="article:publisher" content="https://www.facebook.com/trillmagazine/" />
<meta property="article:published_time" content="2022-09-22T17:26:07+00:00" />
<meta property="article:modified_time" content="2022-09-22T17:31:29+00:00" />
<meta property="og:image" content="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="author" content="Joe Fintan" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@trill_magazine" />
<meta name="twitter:site" content="@trill_magazine" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Joe Fintan" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://www.trillmag.com/entertainment/__trashed-14/#article","isPartOf":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/"},"author":{"name":"Joe Fintan","@id":"https://www.trillmag.com/#/schema/person/e6927a56c4a0f3e38174b2c08584bedf"},"headline":"&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far","datePublished":"2022-09-22T17:26:07+00:00","dateModified":"2022-09-22T17:31:29+00:00","mainEntityOfPage":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/"},"wordCount":251,"commentCount":0,"publisher":{"@id":"https://www.trillmag.com/#organization"},"image":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/#primaryimage"},"thumbnailUrl":"https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg","keywords":["Shadow and Bone","Shadow and Bone season 2","Shadow and Bone season 2 release updates","trillmag"],"articleSection":["Entertainment","TV &amp; Film"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.trillmag.com/entertainment/__trashed-14/#respond"]}],"copyrightYear":"2022","copyrightHolder":{"@id":"https://www.trillmag.com/#organization"}},{"@type":"WebPage","@id":"https://www.trillmag.com/entertainment/__trashed-14/","url":"https://www.trillmag.com/entertainment/__trashed-14/","name":"'Shadow and Bone' Season 2 Release Date: What We Know So Far - Trill Mag","isPartOf":{"@id":"https://www.trillmag.com/#website"},"primaryImageOfPage":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/#primaryimage"},"image":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/#primaryimage"},"thumbnailUrl":"https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg","datePublished":"2022-09-22T17:26:07+00:00","dateModified":"2022-09-22T17:31:29+00:00","description":"Shadow and Bone, Know about Shadow and Bone season 2's Release Updates","breadcrumb":{"@id":"https://www.trillmag.com/entertainment/__trashed-14/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.trillmag.com/entertainment/__trashed-14/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.trillmag.com/entertainment/__trashed-14/#primaryimage","url":"https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg","contentUrl":"https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg","width":1024,"height":576,"caption":"Shadow and Bone, Shadow and Bone season 2, Shadow and Bone season 2 release updates"},{"@type":"BreadcrumbList","@id":"https://www.trillmag.com/entertainment/__trashed-14/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.trillmag.com/"},{"@type":"ListItem","position":2,"name":"&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far"}]},{"@type":"WebSite","@id":"https://www.trillmag.com/#website","url":"https://www.trillmag.com/","name":"Trill Mag","description":"The Voice of Gen-Z","publisher":{"@id":"https://www.trillmag.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.trillmag.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.trillmag.com/#organization","name":"Trill Mag","url":"https://www.trillmag.com/","sameAs":["https://www.instagram.com/trill_mag/","https://www.facebook.com/trillmagazine/","https://twitter.com/trill_magazine"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.trillmag.com/#/schema/logo/image/","url":"https://www.trillmag.com/wp-content/uploads/2022/07/Trill-Mag-Logo-black.png","contentUrl":"https://www.trillmag.com/wp-content/uploads/2022/07/Trill-Mag-Logo-black.png","width":468,"height":54,"caption":"Trill Mag"},"image":{"@id":"https://www.trillmag.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://www.trillmag.com/#/schema/person/e6927a56c4a0f3e38174b2c08584bedf","name":"Joe Fintan","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.trillmag.com/#/schema/person/image/","url":"https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-96x96.jpg","contentUrl":"https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-96x96.jpg","caption":"Joe Fintan"},"url":"https://www.trillmag.com/author/joe-fintan/"}]}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Trill Mag &raquo; Feed" href="https://www.trillmag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trill Mag &raquo; Comments Feed" href="https://www.trillmag.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trill Mag &raquo; &#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far Comments Feed" href="https://www.trillmag.com/entertainment/__trashed-14/feed/" />
<link rel='stylesheet' id='ql-jquery-ui-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-child-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='zox-fonts-css' href='//fonts.googleapis.com/css?family=Heebo%3A300%2C400%2C500%2C700%2C800%2C900%7CAlegreya%3A400%2C500%2C700%2C800%2C900%7CJosefin+Sans%3A300%2C400%2C600%2C700%7CLibre+Franklin%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CFrank+Ruhl+Libre%3A300%2C400%2C500%2C700%2C900%7CNunito+Sans%3A300%2C400%2C600%2C700%2C800%2C900%7CMontserrat%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CAnton%3A400%7CNoto+Serif%3A400%2C700%7CNunito%3A300%2C400%2C600%2C700%2C800%2C900%7CRajdhani%3A300%2C400%2C500%2C600%2C700%7CTitillium+Web%3A300%2C400%2C600%2C700%2C900%7CPT+Serif%3A400%2C400i%2C700%2C700i%7CAmiri%3A400%2C400i%2C700%2C700i%7COswald%3A300%2C400%2C500%2C600%2C700%7CRoboto+Mono%3A400%2C700%7CBarlow+Semi+Condensed%3A700%2C800%2C900%7CPoppins%3A300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto+Condensed%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C500%2C700%2C900%7CPT+Serif%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A700%7CSource+Serif+Pro%3A400%2C600%2C700%7CIM+Fell+French+Canon%3A400%2C400i%7CRoboto%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto+Condensed%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto+Condensed%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto+Condensed%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%7CRoboto%3A100%2C100i%2C200%2C+200i%2C300%2C300i%2C400%2C400i%2C500%2C500i%2C600%2C600i%2C700%2C700i%2C800%2C800i%2C900%2C900i%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' />
<script type='text/javascript' src='https://www.trillmag.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_d09f4e4220319108dfa40b4edc4f818b.js?ver=1.7.1' id='history.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/plugins/theia-post-slider/js/async.min.js?ver=14.09.2014' id='async.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_84cf6af6d7d6c2425f5d280bf010f484.js?ver=1.15.1' id='theiaPostSlider/theiaPostSlider.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_57ec86939964fe4c328c72394ccb21a2.js?ver=1.15.1' id='theiaPostSlider/main.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_dfc79e6337ee81ba1ea69639abcf24d3.js?ver=1.15.1' id='theiaPostSlider/transition.js-js'></script>
<link rel="https://api.w.org/" href="https://www.trillmag.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.trillmag.com/wp-json/wp/v2/posts/117301" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.trillmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.trillmag.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.2" />
<link rel='shortlink' href='https://www.trillmag.com/?p=117301' />
<link rel="alternate" type="application/json+oembed" href="https://www.trillmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trillmag.com%2Fentertainment%2F__trashed-14%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.trillmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trillmag.com%2Fentertainment%2F__trashed-14%2F&#038;format=xml" />
<meta name="theme-color" content="#000" />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98-1024x576.jpg" />
<meta name="twitter:image" content="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98-1024x576.jpg" />
<meta property="og:url" content="https://www.trillmag.com/entertainment/__trashed-14/" />
<meta property="og:title" content="&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far" />
<meta property="og:description" content="The wait for Shadow and Bone season 2 has been exhausting! The last season ended with so many cliffhangers, such as: Kirigan or the Darkling are still alive &#8211; though the main characters are not aware of that yet. Alina needs to work on enhancing her magic, Nina and Matthias are not on good terms, [&hellip;]" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:url" content="https://www.trillmag.com/entertainment/__trashed-14/">
<meta name="twitter:title" content="&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far">
<meta name="twitter:description" content="The wait for Shadow and Bone season 2 has been exhausting! The last season ended with so many cliffhangers, such as: Kirigan or the Darkling are still alive &#8211; though the main characters are not aware of that yet. Alina needs to work on enhancing her magic, Nina and Matthias are not on good terms, [&hellip;]">
<link rel="icon" href="https://www.trillmag.com/wp-content/uploads/2022/09/cropped-ab-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.trillmag.com/wp-content/uploads/2022/09/cropped-ab-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.trillmag.com/wp-content/uploads/2022/09/cropped-ab-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.trillmag.com/wp-content/uploads/2022/09/cropped-ab-270x270.png" />
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2124060854232786" crossorigin="anonymous"></script>
<script async src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-55434826-1', 'auto');
  ga('send', 'pageview');
</script>
</head>
<body class="post-template-default single single-post postid-117301 single-format-standard wp-embed-responsive theiaPostSlider_body zox-ent2 zox-s3">
<div id="zox-site" class="left zoxrel ">
<div id="zox-fly-wrap">
<div id="zox-fly-menu-top" class="left relative">
<div id="zox-fly-logo" class="left relative">
<a href="https://www.trillmag.com/"><img src="https://www.trillmag.com/wp-content/uploads/2022/07/Screen_Shot_2018-02-27_at_10.18.02_PM.png" alt="Trill Mag" data-rjs="2" /></a>
</div>

<div class="zox-fly-but-wrap zox-fly-but-menu zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>

</div>

<div id="zox-fly-menu-wrap">
<nav class="zox-fly-nav-menu left relative">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-107005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-107005"><a href="https://www.trillmag.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-107006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107006"><a href="https://www.trillmag.com/category/news/politics/">Politics</a></li>
<li id="menu-item-107007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107007"><a href="https://www.trillmag.com/category/news/sport/">Sport</a></li>
<li id="menu-item-107008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107008"><a href="https://www.trillmag.com/category/news/tech/">Tech</a></li>
</ul>
</li>
<li id="menu-item-107010" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-107010"><a href="https://www.trillmag.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu">
<li id="menu-item-107009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107009"><a href="https://www.trillmag.com/category/entertainment/celebrity/">Celebrity</a></li>
<li id="menu-item-107013" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-107013"><a href="https://www.trillmag.com/category/entertainment/tv-film/">TV &amp; Film</a></li>
<li id="menu-item-107011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107011"><a href="https://www.trillmag.com/category/entertainment/gaming/">Gaming</a></li>
<li id="menu-item-107012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107012"><a href="https://www.trillmag.com/category/entertainment/music/">Music</a></li>
</ul>
</li>
<li id="menu-item-107014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-107014"><a href="https://www.trillmag.com/category/culture/">Culture</a>
<ul class="sub-menu">
<li id="menu-item-107015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107015"><a href="https://www.trillmag.com/category/culture/art/">Art</a></li>
<li id="menu-item-107017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107017"><a href="https://www.trillmag.com/category/culture/photo/">Photo</a></li>
<li id="menu-item-107016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107016"><a href="https://www.trillmag.com/category/culture/fashion/">Fashion</a></li>
</ul>
</li>
<li id="menu-item-107018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-107018"><a href="https://www.trillmag.com/category/life/">Life</a>
<ul class="sub-menu">
<li id="menu-item-107021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107021"><a href="https://www.trillmag.com/category/life/food-drink/">Food &amp; Drink</a></li>
<li id="menu-item-107019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107019"><a href="https://www.trillmag.com/category/life/college/">College</a></li>
<li id="menu-item-107022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107022"><a href="https://www.trillmag.com/category/life/social-media/">Social Media</a></li>
<li id="menu-item-107023" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107023"><a href="https://www.trillmag.com/category/life/travel/">Travel</a></li>
<li id="menu-item-107020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107020"><a href="https://www.trillmag.com/category/life/drugs/">Drugs</a></li>
</ul>
</li>
<li id="menu-item-107024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107024"><a href="https://www.trillmag.com/category/videos/">Videos</a></li>
</ul></div> </nav>
</div>

<div id="zox-fly-soc-wrap">
<span class="zox-fly-soc-head">Connect with us</span>
<ul class="zox-fly-soc-list left relative">
<li><a href="https://www.facebook.com/trillmagazine/" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/trill_magazine?lang=en" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/trill_mag/" target="_blank" class="fab fa-instagram"></a></li>
</ul>
</div>

</div>
 <div id="zox-search-wrap">
<div class="zox-search-cont">
<p class="zox-search-p">Hi, what are you looking for?</p>
<div class="zox-search-box">
<form method="get" id="zox-search-form" action="https://www.trillmag.com/">
<input type="text" name="s" id="zox-search-input" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "Search") { this.value = ""; }' />
<input type="submit" id="zox-search-submit" value="Search" />
</form> </div>
</div>
<div class="zox-search-but-wrap zox-search-click">
<span></span>
<span></span>
</div>
</div>
<div id="zox-site-wall" class="left zoxrel">
<div id="zox-lead-top-wrap">
<div id="zox-lead-top-in">
<div id="zox-lead-top">
</div>
</div>
</div>
<div id="zox-site-main" class="left zoxrel">
<header id="zox-main-head-wrap" class="left zoxrel zox-trans-head">
<div id="zox-bot-head-wrap" class="left zoxrel">
<div class="zox-head-width">
<div id="zox-bot-head">
<div id="zox-bot-head-left">
<div class="zox-fly-but-wrap zoxrel zox-fly-but-click">
<span></span>
<span></span>
<span></span>
<span></span>
</div>
</div>
<div id="zox-bot-head-mid" class="relative">
<div class="zox-bot-head-logo">
<div class="zox-bot-head-logo-main">
<a href="https://www.trillmag.com/"><img class="zox-logo-stand" src="https://www.trillmag.com/wp-content/uploads/2022/07/Trill-Mag-Logo-black.png" alt="Trill Mag" data-rjs="2" /><img class="zox-logo-dark" src="" alt="Trill Mag" data-rjs="2" /></a>
</div>
<h2 class="zox-logo-title">Trill Mag</h2>
</div>
<div class="zox-bot-head-menu">
<div class="zox-nav-menu">
</div>
</div>
</div>
<div id="zox-bot-head-right">
<span class="zox-nav-search-but fas fa-search zox-search-click"></span>
</div>
</div>
</div>
</div> </header>
<div id="zox-site-grid">
<div id="zox-site-wall-small">
<div id="zox-main-body-wrap" class="left relative"> <article id="post-117301" class="post-117301 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment category-tv-film tag-shadow-and-bone tag-shadow-and-bone-season-2 tag-shadow-and-bone-season-2-release-updates tag-trillmag" itemscope itemtype="http://schema.org/NewsArticle">
<div class="zox-article-wrap zoxrel left zox100">
<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.trillmag.com/entertainment/__trashed-14/" />
<div class="zox-post-top-wrap zoxrel left zox100">
<div class="zox-post-title-wrap zox-tit2">
<div class="zox-post-width">
<header class="zox-post-head-wrap left zoxrel zox100">
<div class="zox-post-head zoxrel">
<h3 class="zox-post-cat">
<a class="zox-post-cat-link" href="https://www.trillmag.com/category/entertainment/"><span class="zox-post-cat">Entertainment</span></a>
</h3>
<h1 class="zox-post-title left entry-title" itemprop="headline">&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far</h1>
<div class="zox-post-info-wrap">
<div class="zox-post-byline-wrap">
<div class="zox-author-thumb">
<img alt='Avatar photo' src='https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-40x40.jpg' srcset='https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-80x80.jpg 2x' class='avatar avatar-40 photo' height='40' width='40' loading='lazy' /> </div>
<div class="zox-author-info-wrap">
<div class="zox-author-name-wrap" itemprop="author" itemscope itemtype="https://schema.org/Person">
<p>By</p><span class="zox-author-name vcard fn author" itemprop="name"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span>
</div>
<div class="zox-post-date-wrap">
<p>Published</p> <span class="zox-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-09-22">2 hours ago</time></span>
<meta itemprop="dateModified" content="2022-09-22" />
</div>
</div>
</div>
<div class="zox-post-soc-top-wrap">
<div class="zox-post-soc-stat">
<ul class="zox-post-soc-stat-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.trillmag.com/entertainment/__trashed-14/&amp;t=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far -&amp;url=https://www.trillmag.com/entertainment/__trashed-14/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<a href="https://www.trillmag.com/entertainment/__trashed-14/#respond">
<li class="zox-post-soc-com zox-com-click">
<i class="far fa-comment"></i>
</li>
</a>
<li class="zox-post-soc-more zox-soc-stat-click-117301">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-stat zox-more-click-117301">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far&url=https://www.trillmag.com/entertainment/__trashed-14/&utm_medium=article-share&utm_campaign=tools&utm_source=Trill Mag', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://www.trillmag.com/entertainment/__trashed-14/&title=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
<i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://www.trillmag.com/entertainment/__trashed-14/&amp;media=https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg&amp;description=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far https://www.trillmag.com/entertainment/__trashed-14/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far https://www.trillmag.com/entertainment/__trashed-14/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#a39cd0d6c1c9c6c0d79e85809b91929598f0cbc2c7ccd483c2cdc783e1cccdc685809b9192949883f0c6c2d0cccd839183f1c6cfc6c2d0c683e7c2d7c69983f4cbc2d783f4c683e8cdccd483f0cc83e5c2d185c2ced398e1ece7fa9eea83c5ccd6cdc783d7cbcad083c2d1d7cac0cfc683cacdd7c6d1c6d0d7cacdc483c2cdc783d7cbccd6c4cbd783ccc583d0cbc2d1cacdc483cad783d4cad7cb83daccd68d83e0cbc6c0c883cad783ccd6d79983cbd7d7d3d0998c8cd4d4d48dd7d1cacfcfcec2c48dc0ccce8cc6cdd7c6d1d7c2cacdcec6cdd78cfcfcd7d1c2d0cbc6c78e92978c">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>

</li>
</ul>
</div>

</div>
</div>
</div>
</header> </div>
</div>
</div>
<div class="zox-post-main-grid">
<div class="zox-post-width">
<div class="zox-post-main-wrap zoxrel left zox100">
<div class="zox-post-main">
<div class="zox-post-bot-wrap">
<div class="zox-post-img-wrap">
<div class="zox-post-img left zoxrel zoxlh0" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
<img width="1024" height="576" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg" class="flipboard-image wp-post-image" alt="Shadow and Bone, Shadow and Bone season 2, Shadow and Bone season 2 release updates" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg 1024w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98-600x337.jpg 600w" sizes="(max-width: 1024px) 100vw, 1024px" /> <meta itemprop="url" content="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg">
<meta itemprop="width" content="1024">
<meta itemprop="height" content="576">
</div>

<span class="zox-post-img-cap">
Image Credit: Netflix 
</div>
</div>
<div class="zox-post-body-wrap left zoxrel">
<div class="zox-post-body left zoxrel zox100">
<div id="tps_slideContainer_117301" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">
<p><strong>The wait for Shadow and Bone season 2 has been exhausting!</strong></p>
<p>The last season ended with so many cliffhangers, such as:</p>
<p>Kirigan or the Darkling are still alive &#8211; though the main characters are not aware of that yet. Alina needs to work on enhancing her magic, Nina and Matthias are not on good terms, and everyone&#8217;s favorite Crows set out on a new adventure.</p>
<p>Fans have known about the second season&#8217;s arrival since Netflix announced the news in June 2021. Surprisingly, it&#8217;s still not here, and fans are still waiting for a release date. However, we can make some wild guesses about when we can see our beloved Shadow Summoner Alina and First Army soldier Mal once again.</p>
<p>Filming for the second season started in January 2022 and ended on June 6th. The exact date was announced on Twitter by the lovely cast. So it required about five months to finish production.</p>
<p>We must not forget that the fantasy series requires lots of visual effects, which means that post-production can take quite a while. That&#8217;s one of the reasons why the fourth season of Stranger Things took so long to finish. Shadow and Bone season 2 will consist of eight episodes.</p>
<p>We might not see this sophomore season until early 2023. But this is just a prediction. To know the exact dates, we will have to wait, and we might get some updates at the TUDUM event.</p>
<p>For more updates, refer to our website.</p>
</div></div><div class="theiaPostSlider_footer _footer"></div><p></p><div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_117301&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/www.trillmag.com\/entertainment\/__trashed-14\/&quot;,&quot;postId&quot;:117301,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/www.trillmag.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-left\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-right\&quot;&gt;&lt;\/span&gt;&quot;}' data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div> </div>
<div class="zox-post-body-bot left zoxrel zox100">
<div class="zox-post-body-width">
<div class="zox-post-tags left zoxrel zox100">
<span class="zox-post-tags-header">In this article:</span><span itemprop="keywords"><a href="https://www.trillmag.com/tag/shadow-and-bone/" rel="tag">Shadow and Bone</a>, <a href="https://www.trillmag.com/tag/shadow-and-bone-season-2/" rel="tag">Shadow and Bone season 2</a>, <a href="https://www.trillmag.com/tag/shadow-and-bone-season-2-release-updates/" rel="tag">Shadow and Bone season 2 release updates</a>, <a href="https://www.trillmag.com/tag/trillmag/" rel="tag">trillmag</a></span>
</div>
<div class="zox-posts-nav-link">
</div>
<div class="zox-author-box-wrap left zoxrel">
<div class="zox-author-box-img zoxrel">
<img alt='Avatar photo' src='https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-150x150.jpg' srcset='https://www.trillmag.com/wp-content/uploads/2022/09/cropped-shutterstock_640011838-300x300.jpg 2x' class='avatar avatar-150 photo' height='150' width='150' loading='lazy' /> </div>
<div class="zox-author-box-right">
<div class="zox-author-box-head zoxrel">
<div class="zox-author-box-name-wrap">
<span class="zox-author-box-name-head zoxrel">Written By</span>
<span class="zox-author-box-name zoxrel"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span>
</div>
</div>
<div class="zox-author-box-text left zoxrel">
<p></p>
</div>
</div>
</div>
<div class="zox-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div class="zox-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<img src="https://www.trillmag.com/wp-content/uploads/2022/07/Trill-Mag-Logo-black.png" />
<meta itemprop="url" content="https://www.trillmag.com/wp-content/uploads/2022/07/Trill-Mag-Logo-black.png">
</div>
<meta itemprop="name" content="Trill Mag">
</div>
<div id="zox-comments-button" class="left zoxrel zox-com-click-117301 zox-com-but-117301">
<span class="zox-comment-but-text"><i class="fas fa-comment"></i> Click to comment</span>
</div>
<div id="comments" class="zox-com-click-id-117301 zox-com-click-main">
<p>




</p>
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title"><div class="zox-post-main-head"><h4 class="zox-post-main-title"><span class="zox-post-main-title">Leave a Reply</span></h4></div> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/entertainment/__trashed-14/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.trillmag.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.trillmag.com%2Fentertainment%2F__trashed-14%2F">logged in</a> to post a comment.</p> </div>
</div>
 </div>
</div>
</div> </div>
<div class="zox-post-side-wrap zox-post-side-noalp zoxrel zox-sticky-side">
<div id="zox-side-wrap" class="zoxrel zox-divs">
<div id="zox_ad_widget-10" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2124060854232786" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2124060854232786" data-ad-slot="8144688831" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div><div id="zox_side_trend_widget-5" class="zox-side-widget zox_side_trend_widget"><div class="zox-widget-side-head"><h4 class="zox-widget-side-title"><span class="zox-widget-side-title">Trending</span></h4></div>
<div class="zox-widget-side-trend-wrap left zoxrel zox100">
<section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://www.trillmag.com/life/what-is-shadow-work-and-why-does-it-matter/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/shutterstock_1430461481-100x100.jpg" class="lazy-load wp-post-image" alt="Shadow work" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/shutterstock_1430461481-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/shutterstock_1430461481-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Life</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/life/what-is-shadow-work-and-why-does-it-matter/" rel="bookmark">
<h2 class="zox-s-title3">What Is Shadow Work And Why Does It Matter?</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://www.trillmag.com/life/social-media/could-you-actually-wear-this-as-a-teacher-this-trend-sparked-the-great-clothing-debate/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/cover-100x100.jpg" class="lazy-load wp-post-image" alt="Teacher fashion TikTok" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/cover-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/cover-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Life</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/life/social-media/could-you-actually-wear-this-as-a-teacher-this-trend-sparked-the-great-clothing-debate/" rel="bookmark">
<h2 class="zox-s-title3">&#8220;Could You Actually Wear This As A Teacher?&#8221;: This Trend Sparked The Great Clothing Debate</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://www.trillmag.com/culture/illumicrate-books-red-white-royally-out-of-touch/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/179FAFAF-6C0E-4356-92C4-B118B42246CB-100x100.jpeg" class="lazy-load wp-post-image" alt="Illumicrate Books" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/179FAFAF-6C0E-4356-92C4-B118B42246CB-100x100.jpeg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/179FAFAF-6C0E-4356-92C4-B118B42246CB-150x150.jpeg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Culture</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/culture/illumicrate-books-red-white-royally-out-of-touch/" rel="bookmark">
<h2 class="zox-s-title3">Illumicrate Books: Red, White, &amp; Royally Out of Touch</h2>
</a>
</div>
</div> </div>
</section> <section class="zox-art-wrap zoxrel zox-art-small">
<div class="zox-art-grid">
<a href="https://www.trillmag.com/culture/capturing-the-essence-of-place-a-photographers-journey/" rel="bookmark">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/adriana-and-tito-in-Panama-100x100.jpg" class="lazy-load wp-post-image" alt="Marianna Asimakopoulou" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/adriana-and-tito-in-Panama-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/adriana-and-tito-in-Panama-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </div>
</a>
<div class="zox-art-text">
<h3 class="zox-s-cat"><span class="zox-s-cat">Culture</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/culture/capturing-the-essence-of-place-a-photographers-journey/" rel="bookmark">
<h2 class="zox-s-title3">Capturing The Essence of Place: A Photographer&#8217;s Journey</h2>
</a>
</div>
</div> </div>
</section> </div>
</div><div id="zox_ad_widget-7" class="zox-side-widget zox_ad_widget"> <div class="zox-widget-ad left relative">
<span class="zox-ad-label">Advertisement</span>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2124060854232786" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-2124060854232786" data-ad-slot="2780681518" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
</div> </div>
</div>
</div>
</div>
</div>
<div class="zox-post-soc-scroll">
<ul class="zox-post-soc-list left zoxrel">
<a href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.trillmag.com/entertainment/__trashed-14/&amp;t=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
<li class="zox-post-soc-fb">
<i class="fab fa-facebook-f"></i>
</li>
</a>
<a href="#" onclick="window.open('https://twitter.com/share?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far -&amp;url=https://www.trillmag.com/entertainment/__trashed-14/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
<li class="zox-post-soc-twit">
<i class="fab fa-twitter"></i>
</li>
</a>
<li class="zox-post-soc-copy">
<i class="fas fa-link"></i>
</li>
<a href="https://www.trillmag.com/entertainment/__trashed-14/#respond">
<li class="zox-post-soc-com zox-com-click">
<i class="far fa-comment"></i>
</li>
</a>
<li class="zox-post-soc-more zox-soc-scroll-click">
<i class="fas fa-ellipsis-h"></i>
<div class="zox-soc-more-scroll">
<ul class="zox-soc-more-list">
<a href="#" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?v=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far&url=https://www.trillmag.com/entertainment/__trashed-14/&utm_medium=article-share&utm_campaign=tools&utm_source=Trill Mag', 'flipboardShare', 'width=626,height=436'); return false;" title="Share on Flipboard">
<li class="zox-post-soc-flip">
<p>Flipboard</p>
<i class="fab fa-flipboard"></i>
</li>
</a>
<a href="#" onclick="window.open('https://www.reddit.com/submit?url=https://www.trillmag.com/entertainment/__trashed-14/&title=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'redditShare', 'width=626,height=436'); return false;" title="Share on Reddit">
<li class="zox-post-soc-redd">
<p>Reddit</p>
 <i class="fab fa-reddit-alien"></i>
</li>
</a>
<a href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https://www.trillmag.com/entertainment/__trashed-14/&amp;media=https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-98.jpg&amp;description=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
<li class="zox-post-soc-pin">
<p>Pinterest</p>
<i class="fab fa-pinterest-p" aria-hidden="true"></i>
</li>
</a>
<a class="zox-whats-main" href="https://web.whatsapp.com/send?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far https://www.trillmag.com/entertainment/__trashed-14/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a class="zox-whats-mob" href="whatsapp://send?text=&#8216;Shadow and Bone&#8217; Season 2 Release Date: What We Know So Far https://www.trillmag.com/entertainment/__trashed-14/">
<li class="zox-post-soc-what">
<p>Whatsapp</p>
<i class="fab fa-whatsapp"></i>
</li>
</a>
<a href="/cdn-cgi/l/email-protection#8cb3fff9eee6e9eff8b1aaafb4bebdbab7dfe4ede8e3fbacede2e8accee3e2e9aaafb4bebdbbb7acdfe9edffe3e2acbeacdee9e0e9edffe9acc8edf8e9b6acdbe4edf8acdbe9acc7e2e3fbacdfe3accaedfeaaede1fcb7cec3c8d5b1c5aceae3f9e2e8acf8e4e5ffacedfef8e5efe0e9ace5e2f8e9fee9fff8e5e2ebacede2e8acf8e4e3f9ebe4f8ace3eaacffe4edfee5e2ebace5f8acfbe5f8e4acf5e3f9a2accfe4e9efe7ace5f8ace3f9f8b6ace4f8f8fcffb6a3a3fbfbfba2f8fee5e0e0e1edeba2efe3e1a3e9e2f8e9fef8ede5e2e1e9e2f8a3d3d3f8feedffe4e9e8a1bdb8a3">
<li class="zox-post-soc-email">
<p>Email</p>
<i class="fas fa-envelope"></i>
</li>
</a>
</ul>
</div>

</li>
</ul>
</div>

</div>
<div class="zox-post-more-wrap left zoxrel zox100">
<div class="zox-post-width">
<div class="zox-post-more left zoxrel zox100">
<div class="zox-post-main-head left zoxrel zox100">
<h4 class="zox-post-main-title">
<span class="zox-post-main-title">You May Also Like</span>
</h4>
</div>
<div class="zox-post-more-grid zox-div4 left zoxrel zox100">
<div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/monster-the-jeffrey-dahmer-story-did-dahmer-really-feed-human-meat-to-his-neighbors/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99-600x337.jpg" class="zox-reg-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story release date, Monster: The Jeffrey Dahmer Story cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99-100x100.jpg" class="zox-mob-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story release date, Monster: The Jeffrey Dahmer Story cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-99-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/monster-the-jeffrey-dahmer-story-did-dahmer-really-feed-human-meat-to-his-neighbors/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;Monster: The Jeffrey Dahmer Story&#8217;: Did Dahmer Really Feed Human Meat to His Neighbors?</h2>
</a>
</div>
<p class="zox-s-graph">&#8216;Monster: The Jeffrey Dahmer Story&#8217; is a dark drama based on true events. It arrived on Netflix yesterday and might not be for the...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>2 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/even-peters-net-worth-how-much-is-the-jeffrey-dahmer-story-star-worth/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95-600x337.jpg" class="zox-reg-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story cast, Monster: The Jeffrey Dahmer Story plot, Monster: The Jeffrey Dahmer Story netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95-100x100.jpg" class="zox-mob-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story cast, Monster: The Jeffrey Dahmer Story plot, Monster: The Jeffrey Dahmer Story netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-95-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/even-peters-net-worth-how-much-is-the-jeffrey-dahmer-story-star-worth/" rel="bookmark">
<h2 class="zox-s-title2">Even Peters&#8217; Net Worth: How Much is &#8216;The Jeffrey Dahmer Story&#8217; Star Worth?</h2>
</a>
</div>
<p class="zox-s-graph">Actor Evan Peters is best known for his roles in movies and TV. The actor recently portrayed serial killer and sex offender Jeffrey Dahmer...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>2 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/a-jazzmans-blues-age-ratings-is-the-tyler-perry-movie-appropriate-for-kids/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97-600x337.jpg" class="zox-reg-img wp-post-image" alt="A Jazzman’s Blues, A Jazzman’s Blues age ratings, A Jazzman’s Blues plot, A Jazzman’s Blues cast, A Jazzman’s Blues Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97-100x100.jpg" class="zox-mob-img wp-post-image" alt="A Jazzman’s Blues, A Jazzman’s Blues age ratings, A Jazzman’s Blues plot, A Jazzman’s Blues cast, A Jazzman’s Blues Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-97-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/a-jazzmans-blues-age-ratings-is-the-tyler-perry-movie-appropriate-for-kids/" rel="bookmark">
<h2 class="zox-s-title2">A Jazzman’s Blues Age Ratings: Is the Tyler Perry Movie Appropriate For Kids?</h2>
</a>
</div>
<p class="zox-s-graph">The release of Tyler Perry&#8217;s A Jazzman&#8217;s Blues on Netflix is approaching, but before viewing the film, it is advised to be aware of...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>2 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/my-friend-dahmer-where-to-watch-plot-cast-and-everything-else-you-need-to-know/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96-600x337.jpg" class="zox-reg-img wp-post-image" alt="My Friend Dahmer, My Friend Dahmer Cast, My Friend Dahmer plot" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96-100x100.jpg" class="zox-mob-img wp-post-image" alt="My Friend Dahmer, My Friend Dahmer Cast, My Friend Dahmer plot" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-96-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/my-friend-dahmer-where-to-watch-plot-cast-and-everything-else-you-need-to-know/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;My Friend Dahmer&#8217;: Where to Watch, Plot, Cast, And Everything Else You Need to Know</h2>
</a>
</div>
<p class="zox-s-graph">People are gearing up for Netflix&#8217;s Monster: The Jeffrey Dahmer Story by watching all of the films and documentaries about the notorious serial killer....</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/joe-fintan/" title="Posts by Joe Fintan" rel="author">Joe Fintan</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>2 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/nailed-it-season-7-release-date-synopsis-official-trailer-and-more/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94-600x337.jpg" class="zox-reg-img wp-post-image" alt="Nailed It! season 7, Nailed It! season 7 Release Date, Nailed It! season 7 Cast," loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94-100x100.jpg" class="zox-mob-img wp-post-image" alt="Nailed It! season 7, Nailed It! season 7 Release Date, Nailed It! season 7 Cast," loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-94-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/nailed-it-season-7-release-date-synopsis-official-trailer-and-more/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;Nailed It!&#8217; Season 7 Release Date, Synopsis, Official Trailer, And More</h2>
</a>
</div>
<p class="zox-s-graph">Nailed It! season 7 will come out soon. You can&#8217;t stop watching Nailed It! season 6 because both good and terrible cakes were made...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/sean-lloyd/" title="Posts by Sean Lloyd" rel="author">Sean Lloyd</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>6 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/is-the-case-against-adnan-syed-available-on-netflix/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93-600x337.jpg" class="zox-reg-img wp-post-image" alt="The Case Against Adnan Syed, The Case Against Adnan Syed plot, The Case Against Adnan Syed cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93-100x100.jpg" class="zox-mob-img wp-post-image" alt="The Case Against Adnan Syed, The Case Against Adnan Syed plot, The Case Against Adnan Syed cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-93-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/is-the-case-against-adnan-syed-available-on-netflix/" rel="bookmark">
<h2 class="zox-s-title2">Is &#8216;The Case Against Adnan Syed&#8217; Available on Netflix?</h2>
</a>
</div>
<p class="zox-s-graph">One of the best well-made true crime documentaries out there has to be The Case Against Adnan Syed. The four-part docuseries premiered on HBO...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/sean-lloyd/" title="Posts by Sean Lloyd" rel="author">Sean Lloyd</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>7 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/how-and-when-did-jeffrey-dahmer-die/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92-600x337.jpg" class="zox-reg-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story release date, Monster: The Jeffrey Dahmer Story cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92-100x100.jpg" class="zox-mob-img wp-post-image" alt="Monster: The Jeffrey Dahmer Story, Monster: The Jeffrey Dahmer Story release date, Monster: The Jeffrey Dahmer Story cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-92-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/how-and-when-did-jeffrey-dahmer-die/" rel="bookmark">
<h2 class="zox-s-title2">How and When Did Jeffrey Dahmer Die?</h2>
</a>
</div>
<p class="zox-s-graph">Evan Peters plays the notorious serial killer in the 10-episode show by Ryan Murphy and Ian Brennan, Monster: The Jeffrey Dahmer Story. This new...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/sean-lloyd/" title="Posts by Sean Lloyd" rel="author">Sean Lloyd</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>7 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/monster-the-jeffrey-dahmer-story-cast-list-who-plays-who/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-600x337.jpg" class="zox-reg-img wp-post-image" alt="Jeffrey Dahmer, Jeffrey Dahmer Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-100x100.jpg" class="zox-mob-img wp-post-image" alt="Jeffrey Dahmer, Jeffrey Dahmer Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/monster-the-jeffrey-dahmer-story-cast-list-who-plays-who/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;Monster: The Jeffrey Dahmer Story&#8217; Cast List: Who Plays Who?</h2>
</a>
</div>
<p class="zox-s-graph">Evan Peters is the main attraction in this docuseries, and he will be playing the role of serial killer Jeffrey Dahmer. Along with Peters,...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/sean-lloyd/" title="Posts by Sean Lloyd" rel="author">Sean Lloyd</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>7 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/bling-empire-season-3-release-date-official-trailer-cast-and-everything-we-know/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91-600x337.jpg" class="zox-reg-img wp-post-image" alt="Bling Empire season 3, Bling Empire season 3 release date, Bling Empire season 3 cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91-100x100.jpg" class="zox-mob-img wp-post-image" alt="Bling Empire season 3, Bling Empire season 3 release date, Bling Empire season 3 cast" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-91-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/bling-empire-season-3-release-date-official-trailer-cast-and-everything-we-know/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;Bling Empire&#8217; Season 3: Release Date, Official Trailer, Cast, And Everything We Know</h2>
</a>
</div>
<p class="zox-s-graph">Bling Empire is based on the lives of some wealthy Asians and their Asian American friends who live incredibly glamorous lifestyles in Los Angeles....</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/meuryn-ellis/" title="Posts by Meuryn Ellis" rel="author">Meuryn Ellis</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>8 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/family-reunion-part-5-season-3-netflix-release-date-officially-announced/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90-600x337.jpg" class="zox-reg-img wp-post-image" alt="Family Reunion Part 5, Family Reunion Part 5 release date, Family Reunion Part 5 Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90-100x100.jpg" class="zox-mob-img wp-post-image" alt="Family Reunion Part 5, Family Reunion Part 5 release date, Family Reunion Part 5 Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-90-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/family-reunion-part-5-season-3-netflix-release-date-officially-announced/" rel="bookmark">
<h2 class="zox-s-title2">&#8216;Family Reunion&#8217; Part 5, Season 3: Netflix Release Date Officially Announced</h2>
</a>
</div>
<p class="zox-s-graph">The complete list of Netflix movies and shows coming in October is out, and our favorite Family Reunion is on it. The fifth part...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/meuryn-ellis/" title="Posts by Meuryn Ellis" rel="author">Meuryn Ellis</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>10 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/how-many-people-did-jeffrey-dahmer-kill/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-600x337.jpg" class="zox-reg-img wp-post-image" alt="Jeffrey Dahmer, Jeffrey Dahmer Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-100x100.jpg" class="zox-mob-img wp-post-image" alt="Jeffrey Dahmer, Jeffrey Dahmer Netflix, Netflix" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/kjbdc-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/how-many-people-did-jeffrey-dahmer-kill/" rel="bookmark">
<h2 class="zox-s-title2">How Many People Did Jeffrey Dahmer Kill?</h2>
</a>
</div>
<p class="zox-s-graph">Evan Peters is playing the role of Jeffrey Dahmer in a 10-episode Netflix series titled Monster: The Jeffrey Dahmer Story. On October 7th Netflix...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/mrt/" title="Posts by Tarun Singh" rel="author">Tarun Singh</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>10 hours ago</span>
</div>
</div>
</div> </div>
</div> <div class="zox-art-wrap zoxrel zox-art-mid">
<div class="zox-art-grid">
<div class="zox-art-img zoxrel zox100 zoxlh0">
<a href="https://www.trillmag.com/entertainment/where-to-watch-reboot-starring-keegan-michael-key/" rel="bookmark">
<img width="600" height="337" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89-600x337.jpg" class="zox-reg-img wp-post-image" alt="Reboot, Reboot cast, Reboot plot, Reboot hulu" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89-600x337.jpg 600w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89.jpg 1024w" sizes="(max-width: 600px) 100vw, 600px" /> <img width="100" height="100" src="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89-100x100.jpg" class="zox-mob-img wp-post-image" alt="Reboot, Reboot cast, Reboot plot, Reboot hulu" loading="lazy" srcset="https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89-100x100.jpg 100w, https://www.trillmag.com/wp-content/uploads/2022/09/Your-paragraph-text-89-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" /> </a>
</div>
<div class="zox-art-text">
<div class="zox-art-text-cont">
<h3 class="zox-s-cat"><span class="zox-s-cat">Entertainment</span></h3>
<div class="zox-art-title">
<a href="https://www.trillmag.com/entertainment/where-to-watch-reboot-starring-keegan-michael-key/" rel="bookmark">
<h2 class="zox-s-title2">Where to Watch &#8216;Reboot&#8217; Starring Keegan-Michael Key</h2>
</a>
</div>
<p class="zox-s-graph">Reboot is now streaming, and in this blog, we&#8217;ll tell you where you can watch this new comedy series. Reboot was created by the...</p>
<div class="zox-byline-wrap">
<span class="zox-byline-name"><a href="https://www.trillmag.com/author/meuryn-ellis/" title="Posts by Meuryn Ellis" rel="author">Meuryn Ellis</a></span><span class="zox-byline-date"><i class="far fa-clock"></i>10 hours ago</span>
</div>
</div>
</div> </div>
</div> </div> </div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
	jQuery(document).ready(function($) {
  		$(".zox-soc-stat-click-117301").on("click", function(){
	  		$(".zox-more-click-117301").toggleClass("zox-soc-more-open");
  		});
	});
    </script> </article> </div>
<footer id="zox-foot-wrap" class="left zoxrel zox100">
<div class="zox-head-width">
<div class="zox-foot-grid left zoxrel zox100">
<div class="zox-foot-left-wrap">
<div class="zox-foot-logo left zox-lh0">
<a href="https://www.trillmag.com/"><img src="https://www.trillmag.com/wp-content/uploads/2022/08/footer.png" alt="Trill Mag" data-rjs="2" /></a>
</div>
<div class="zox-foot-left left">
<div class="zox-foot-menu">
<div class="menu-secondary-menu-container"><ul id="menu-secondary-menu" class="menu"><li id="menu-item-107046" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107046"><a href="https://www.trillmag.com/contact/">Contiribute</a></li>
<li id="menu-item-107047" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107047"><a href="https://www.trillmag.com/copyright-statement/">Copyright Statement</a></li>
<li id="menu-item-107045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107045"><a href="https://www.trillmag.com/submit/">Submit</a></li>
<li id="menu-item-107044" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107044"><a href="https://www.trillmag.com/advertise/">Advertise</a></li>
<li id="menu-item-107043" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107043"><a href="https://www.trillmag.com/about-us/">About Us</a></li>
<li id="menu-item-107042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107042"><a href="https://www.trillmag.com/contact-us/">Contact Us</a></li>
</ul></div> </div>
<div class="zox-foot-copy">
 <p>Copyright © 2022 Trill! Mag</p>
</div>
</div>
</div>
<div class="zox-foot-right-wrap">
<div class="zox-foot-soc right relative">
<ul class="zox-foot-soc-list left relative">
<li><a href="https://www.facebook.com/trillmagazine/" target="_blank" class="fab fa-facebook-f"></a></li>
<li><a href="https://twitter.com/trill_magazine?lang=en" target="_blank" class="fab fa-twitter"></a></li>
<li><a href="https://www.instagram.com/trill_mag/" target="_blank" class="fab fa-instagram"></a></li>
</ul>
</div>
</div>
</div>
</div>
</footer>
</div>
</div>
</div>
</div>
<div class="zox-fly-top back-to-top">
<span class="fas fa-angle-up"></span>
</div>
</div>
<div class="zox-fly-fade zox-fly-but-click">
</div>
<div data-theiaStickySidebar-sidebarSelector='".zox-feat-right-wrap, .zox-sticky-side"' data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":65,"additionalMarginBottom":0,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_5bf4cf74118e7fc71e1b6166e21d5524.js?ver=1.7.0' id='theia-sticky-sidebar/ResizeSensor.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_8780a39c54ae9fd4c92c3c491f984e3d.js?ver=1.7.0' id='theia-sticky-sidebar/theia-sticky-sidebar.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_84d0293a31628dc996d081e9bc8d2e87.js?ver=1.7.0' id='theia-sticky-sidebar/main.js-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.sticky-kit.min.js?ver=6.0.2' id='jquery-sticky-kit-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/plugins/zoxpress-plugin//scripts/jquery.waypoints.min.js?ver=6.0.2' id='jquery-waypoints-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/themes/zoxpress/js/zoxcustom.js?ver=6.0.2' id='zox-custom-js'></script>
<script type='text/javascript' id='zox-custom-js-after'>

			jQuery(document).ready(function($) {
			var leaderHeight = $("#zox-lead-top").outerHeight();
			var botHeight = $("#zox-bot-head-wrap").outerHeight();
			var navHeight = $("#zox-main-head-wrap").outerHeight();
			var headerHeight = navHeight + leaderHeight;
			var stickHeight = headerHeight - botHeight;
			var previousScroll = 0;
			$(window).scroll(function(event){
				var scroll = $(this).scrollTop();
				if ( typeof leaderHeight !== "undefined" ) {
					if ($(window).scrollTop() > headerHeight){
						$("#zox-bot-head-wrap").addClass("zox-fix-up");
						$("#zox-site-grid").css("margin-top", botHeight);
						$(".zox-post-soc-scroll").addClass("zox-post-soc-scroll-out");
						$(".zox-fly-top").addClass("zox-to-top");
					} else {
						$("#zox-bot-head-wrap").removeClass("zox-fix-up");
						$("#zox-site-grid").css("margin-top", "0" );
						$(".zox-post-soc-scroll").removeClass("zox-post-soc-scroll-out");
						$(".zox-fly-top").removeClass("zox-to-top");
					}
					if ($(window).scrollTop() > headerHeight - botHeight){
						$("#zox-bot-head-wrap").addClass("zox-fix");
						if(scroll < previousScroll) {
							$("#zox-bot-head-wrap").addClass("zox-fix");
							$("#zox-site-grid").css("margin-top", botHeight);
						} else {
							$("#zox-bot-head-wrap").removeClass("zox-fix");
						}
					} else {
						$("#zox-bot-head-wrap").removeClass("zox-fix");
						$("#zox-site-grid").css("margin-top", "0" );
					}
				} else {
					if ($(window).scrollTop() > navHeight){
						$("#zox-bot-head-wrap").addClass("zox-fix-up");
						$("#zox-site-grid").css("margin-top", botHeight);
						$(".zox-post-soc-scroll").addClass("zox-post-soc-scroll-out");
						$(".zox-fly-top").addClass("zox-to-top");
					} else {
						$("#zox-bot-head-wrap").removeClass("zox-fix-up");
						$("#zox-site-grid").css("margin-top", "0" );
						$(".zox-post-soc-scroll").removeClass("zox-post-soc-scroll-out");
						$(".zox-fly-top").removeClass("zox-to-top");
					}
					if ($(window).scrollTop() > navHeight - botHeight){
						$("#zox-bot-head-wrap").addClass("zox-fix");
						if(scroll < previousScroll) {
							$("#zox-bot-head-wrap").addClass("zox-fix");
							$("#zox-site-grid").css("margin-top", botHeight);
						} else {
							$("#zox-bot-head-wrap").removeClass("zox-fix");
						}
					} else {
						$("#zox-bot-head-wrap").removeClass("zox-fix");
						$("#zox-site-grid").css("margin-top", "0" );
					}
				}
				previousScroll = scroll;
			});
			$(".zox-alp-side-in").niceScroll({cursorcolor:"#ccc",cursorwidth: 5,cursorborder: 0,zindex:999999});
			});
			

	jQuery(document).ready(function($) {
	$(".zox-fly-nav-menu .menu-item-has-children a").click(function(event){
	  event.stopPropagation();
  	});

	$(".zox-fly-nav-menu .menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".zox-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	  $(".zox-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	

	jQuery(document).ready(function($) {
		var headwrap = $("#zox-bot-head-wrap");
		var position = headwrap.offset();
		var headWidth = $("#zox-bot-head-wrap").outerWidth();
		$(".zox-mega-dropdown").css("width", headWidth );
		$(".zox-mega-dropdown").offset({
			left: position.left,
			width: headwrap.offsetWidth
		});
		$(window).resize(function(){
			var headwrap = $("#zox-bot-head-wrap");
			var position = headwrap.offset();
			var headWidth = $("#zox-bot-head-wrap").outerWidth();
			$(".zox-mega-dropdown").css("width", headWidth );
			$(".zox-mega-dropdown").offset({
  				left: position.left,
				width: headwrap.offsetWidth
			});
		});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".zox-nav-links",
	  nextSelector: ".zox-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".zox-inf-more-wrap").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".zox-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	if ($(".zox-nav-links a").length) {
		$(".zox-inf-more-wrap").css("display","inline-block");
	} else {
		$(".zox-inf-more-wrap").css("display","none");
	}
	});
	

			jQuery(document).ready(function($) {
				$(".zox-com-click-117301").on("click", function(){
	  	    	$(".zox-com-click-id-117301").show();
		    	$(".disqus-thread-117301").show();
	  	    	$(".zox-com-but-117301").hide();
		  		});
			});
		
</script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_16911309a6a26f78620b256e62511a52.js?ver=6.0.2' id='zox-scripts-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_04891b9267573e564c2c276fbf96d9cd.js?ver=6.0.2' id='zox-retina-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/themes/zoxpress/js/jquery.infinitescroll.min.js?ver=6.0.2' id='zox-infinitescroll-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/cache/autoptimize/js/autoptimize_single_475e80eab03aa5228bcceb98e0b51d93.js' id='zox-intersection-observer-polyfill-js'></script>
<script type='text/javascript' src='https://www.trillmag.com/wp-content/themes/zoxpress/js/lozad.min.js' id='zox-lozad-js'></script>
<script type='text/javascript' id='zox-lozad-js-after'>

	var zoxWidgets = document.querySelectorAll("#zox-home-widget-wrap img");
	lozad(zoxWidgets, {
		rootMargin: "0px 0px",
		loaded: function (el) {
			el.classList.add("is-loaded");
		}
	}).observe();
</script>
<script>(function(){var js = "window['__CF$cv$params']={r:'74efd36bfaea7fee',m:'8BaqAT0HwEPTWNusfjWAz_yo1n5.IMRo3NQBCyOXioQ-1663899885-0-AbCyKai6h+Ar13VtSkcgmf0Hj1kn7qIVxGZaFIf5LxXDV8d8Ja3Uqt0C7FUdmQdnAJh14cGwrXqHFtaS21oesdTKIjnbJrVWymoxt8v3CH8X9exD5TAcIWFuth0b+zJV22+40hXpNJO9QFuCsSvuZF0=',s:[0xb3a528a6d3,0x4d80bdcf7a],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"74efd36bfaea7fee","token":"bd2e9ecc09c54bd8ab3fef694ade2722","version":"2022.8.1","si":100}' crossorigin="anonymous"></script>
</body>
</html>